Comdata checks not processing

Incident Report for RoadSync

Resolved

Instant Payout and Comdata check processing have returned to normal operational state. We will continue to monitor activity related to the global Amazon Web Services outage.
Posted Oct 20, 2025 - 18:57 EDT

Update

Instant Payouts as well as Comdata checks are processing intermittently on Roadsync platform due to global Amazon Web Services outage. We will keep you informed with updates.
Posted Oct 20, 2025 - 16:07 EDT

Monitoring

Comdata checks are processing intermittently on Roadsync platform due to global Amazon Web Services outage. We will keep you informed with updates.
Posted Oct 20, 2025 - 13:09 EDT
This incident affected: Checkout.