EFS/Wex Payment Methods

Incident Report for RoadSync

Resolved

Our partner has resolved the issue and EFS/Wex payment methods are operational again.
Posted Mar 20, 2024 - 14:13 EDT

Identified

Our partner has identified the issue and is working on a fix.
Posted Mar 20, 2024 - 13:50 EDT

Investigating

We are currently experiencing technical issues with EFS/Wex payment methods. TChecks will continue to work as normal. We have contacted EFS/Wex and raised the issue and are working with them to resolve it.
Posted Mar 20, 2024 - 12:58 EDT
This incident affected: Checkout.