Intermittent payment failures

Incident Report for RoadSync

Resolved

A fix has been identified and implemented. Systems have returned to normal. Please contact your Roadsync Client Services manager if you are experiencing issues.
Posted Mar 05, 2026 - 14:14 EST

Monitoring

A fix has been identified and implemented. We are monitoring the results.
Posted Mar 05, 2026 - 13:17 EST

Update

We are continuing to investigate this issue.
Posted Mar 05, 2026 - 13:16 EST

Investigating

Roadsync is currently experiencing intermittent payment failures due to issues with downstream payment networks. We will keep you apprised as we diagnose and learn more.
Posted Mar 05, 2026 - 12:52 EST
This incident affected: Checkout.