3DS Payment Failures

Incident Report for RoadSync

Resolved

This incident has been resolved.
Posted May 08, 2026 - 22:33 EDT

Update

This issue has been resolved.
Posted May 08, 2026 - 22:32 EDT

Identified

We continue to have issues with 3DS-enabled payments. We have implemented a temporary workaround and will keep you apprised of issue resolution.

In the meantime, please contact your client success team member if you have questions or concerns.
Posted May 08, 2026 - 11:26 EDT

Investigating

We are currently aware of an issue affecting 3DS payments and we will provide updates as they become available.
Posted May 07, 2026 - 21:15 EDT
This incident affected: Checkout.